Help with invalid dBZ values

Hello! I am new to LROSE and I am starting with using fractl to run a dual doppler analysis between mobile radars. While running fractl I encounter this error:

Fractl: throwerr: invalid valDbz: 327.67

libc++abi: terminating due to uncaught exception of type char*

Abort trap: 6

This error comes up for a RaXPol cfradial file. How can I go about fixing this? I have switched out files to try a different time and Im still getting the same error. I appreciate any help! Thank you in advance!

Hi Leah,

Can you send a couple sample files and your parameter file? A google drive or dropbox link would work.


Here is a google drive link. I uploaded 3 RaXPol files and my params.

Thank you!

Sorry I just realized I needed to set up the folder so anyone can view it. It should work now :slight_smile:

Hi Leah,

I noticed some artificially high DBZ1 values close to the radar (~327; which I think is producing the invalid DBZ error). I removed those using RadxQc and I was able to get FRACTL to run (though I’m not sure if the results are as you expect).

You can run the following command to run RadxQc on the 3 files and FRACTL should run then on the output files. I’ve included a link to the parameter file I used for RadxQc.

RadxQc -params ./RadxQc.params -f ./data/*.nc -outdir ./qc_output

You’re also welcome to remove those data values using another method. Let me know if that works for you.


Hi Jen,

This worked for me! Thank you so much :slight_smile: