How to prevent image ghosting with GridForecast

We’re feeding the output of the ctrec application (U and V movement vectors) to the GridForecast application to perform short horizon (120 minutes) radar-based precipitation forecasting. Even when we set the avoid_ghosting parameter to TRUE in the GridForecast TDRP parameters, we observe ghosting more often than not, especially with forecasts of more than 30 minutes.

Anyone else observed this behaviour? I understand ghosting occurs because of the absence of motion vectors. Perhaps our ctrec configuration is the root cause because the ctrec output does have missing vectors in many areas of grid.

Thanks for helping.