MacOS Installing LROSE - qt5 error

Hi, I am trying to install LROSE-Core on MacOS Monterey and keep getting the following error

==> Fetching lrose-core
==> Downloading
Already downloaded: /Users/hvagasky/Library/Caches/Homebrew/downloads/c47fa5307a11a0d653dbd78c0c28edd9fe5467414fa60df19222c660692f36d5–lrose-core-20221229.src.mac_osx.tgz
==> Installing dependencies for lrose-core: qt5
==> Installing lrose-core dependency: qt5
==> Pouring qt@5–5.15.8_3.arm64_monterey.bottle.1.tar.gz
:beer: /Users/hvagasky/homebrew/Cellar/qt@5/5.15.8_3: 10,840 files, 344.4MB
==> Installing lrose-core
==> cmake …
Last 15 lines from /Users/hvagasky/Library/Logs/Homebrew/lrose-core/01.cmake:
HDF5_C_INCLUDE_DIR: /Users/hvagasky/homebrew/Cellar/lrose-core/core-20221229/include
CMAKE_INSTALL_PREFIX is /Users/hvagasky/homebrew/Cellar/lrose-core/core-20221229
CMake Error at libs/qtplot/src/CMakeLists.txt:20 (find_package):

  • Could not find a package configuration file provided by “Qt5” with any of*

  • the following names:*

  • Qt5Config.cmake*

  • qt5-config.cmake*

  • Add the installation prefix of “Qt5” to CMAKE_PREFIX_PATH or set “Qt5_DIR”*

  • to a directory containing one of the above files. If “Qt5” provides a*

  • separate development package or SDK, be sure it has been installed.*

– Configuring incomplete, errors occurred!

Do not report this issue to Homebrew/brew or Homebrew/homebrew-core!

I tried setting all the paths as suggested in the qt5 paths. I also tried uninstalling and reinstalling qt5 and keep getting the same error.

Any suggestions how to get past this error?


For posterity’s sake, here are some comments from the offline discussion:

The standard locations for qt5 in homebrew seem to be:
/usr/local/Cellar/qt@5 (older hardware)
/opt/homebrew/Cellar/qt@5 (M1, M2)
It seems odd that homebrew is in:
I wonder if Hannah has installed homebrew in a non-standard way?
The docs are here:

The solution was to uninstall brew and re-install everything from the beginning so that brew would be in the proper location.