Unable to produce RadxPersistentClutter output

Hello LROSE Forum,

I am having some difficulty running RadxPersistentClutter using the 2 commands outlined here: http://wiki.lrose.net/index.php/RadxPersistentClutter.

Without specifying a -f:
/usr/local/lrose/bin/RadxPersistentClutter -params PersistentClutter_params

The below output occurs, then does not proceed:
18:05:31 DEBUG /tmp/lrose-build/lrose-core/codebase/libs/radar/src/radx/RadxApp.cc[117]:algInit()::setup
18:05:31 DEBUG /tmp/lrose-build/lrose-core/codebase/libs/radar/src/radx/RadxAppVolume.cc[294]:triggerRadxVolume()::
------before trigger----

When specifying a -f:
/usr/local/lrose/bin/RadxPersistentClutter -f /home/lmccarth/radar-files/convert/ -params PersistentClutter_params

I get the following error:

Has anyone encountered either of these errors before and could point me to where I am going wrong?

Thank you,


Hi Lauren,

Did you try including the file extension when running the program with the -f option? I usually get the “unable to open file” error when I haven’t linked to the files properly.

That is:
/usr/local/lrose/bin/RadxPersistentClutter -f /home/lmccarth/radar-files/convert/*.nc -params PersistentClutter_params

Let us know if the problem persists.


1 Like

Hi Jen,

Thank you very much for your response! I have tried a run with adding the f option, but am still getting a file exception error:

I am guessing it’s something to do with my params file. Do you know if this error is related to the input field within the params file?

Thank you again for your help,


Hi Lauren,

It looks like one of the issues was solved, but now there are other errors occurring. Could you send me your data and parameter files so that I can test it on my machine? I’ll see if I can spot anything that’s an issue.